You have been tasked with configuring the network shown in Figure 5-13 using RIPv2 such that:

1. All interfaces on each router are advertised in RIP
2. RouterC should not learn routes from the rest of the network. It should use a default route to reach remote networks. All routers should learn the 172.20.0.0/16 network using RIP
3. All interfaces that do not connect to another router such not advertise RIP routes.
4. Remember that the DCE side of your DTE/DCE back to back cable should be connected to the interface configured with clock rate.

Figure 5-13 Network Setup for Lab 5-1

13

The initial configuration for each router is given below

RouterA

Router(config)#hostname RouterA
RouterA(config)#int fa0/0
RouterA(config-if)#ip address 172.16.0.1 255.255.0.0
RouterA(config-if)#no shut
RouterA(config-if)#exit
RouterA(config)#int s0/0
RouterA(config-if)#ip address 192.168.1.1 255.255.255.252
RouterA(config-if)#no shut
RouterA(config-if)#exit
RouterA(config)#int s0/1
RouterA(config-if)#ip address 192.168.1.9 255.255.255.252
RouterA(config-if)#no shut
RouterA(config-if)#exit

RouterB

Router(config)#hostname RouterB
RouterB(config)#int fa0/0
RouterB(config-if)#ip address 192.168.1.5 255.255.255.252
RouterB(config-if)#no shut
RouterB(config-if)#exit
RouterB(config)#int s0/0
RouterB(config-if)#ip add 192.168.1.2 255.255.255.252
RouterB(config-if)#clock rate 2000000
RouterB(config-if)#no shut
RouterB(config-if)#exit
RouterB(config)#int s0/1
RouterB(config-if)#ip address 192.168.1.13 255.255.255.252
RouterB(config-if)#clock rate 2000000
RouterB(config-if)#no shut
RouterB(config-if)#exit
RouterB(config)#int fa0/1
RouterB(config-if)#ip address 172.18.0.2 255.255.0.0
RouterB(config-if)#no shut
RouterB(config-if)#exit

RouterC

Router(config)#hostname RouterC
RouterC(config)#int fa0/0
RouterC(config-if)#ip address 192.168.1.6 255.255.255.252
RouterC(config-if)#no shut
RouterC(config-if)#exit
RouterC(config)#int s0/0
RouterC(config-if)#ip address 172.20.0.3 255.255.0.0
RouterC(config-if)#no shut
RouterC(config-if)#exit

RouterD

Router(config)#hostname RouterD
RouterD(config)#int fa0/0
RouterD(config-if)#ip address 172.17.0.4 255.255.0.0
RouterD(config-if)#no shut
RouterD(config-if)#exit
RouterD(config)#int s0/0
RouterD(config-if)#clock rate 2000000
RouterD(config-if)#ip address 192.168.1.17 255.255.255.252
RouterD(config-if)#no shut
RouterD(config-if)#exit
RouterD(config)#int s0/1
RouterD(config-if)#ip address 192.168.1.10 255.255.255.252
RouterD(config-if)#clock rate 2000000
RouterD(config-if)#no shut
RouterD(config-if)#exit

RouterE

Router(config)#hostname RouterE
RouterE(config)#int fa0/0
RouterE(config-if)#ip address 172.19.0.5 255.255.0.0
RouterE(config-if)#no shut
RouterE(config-if)#exit
RouterE(config)#int s0/0
RouterE(config-if)#ip address 192.168.1.18 255.255.255.252
RouterE(config-if)#no shut
RouterE(config-if)#exit
RouterE(config)#int s0/1
RouterE(config-if)#ip address 192.168.1.14 255.255.255.252
RouterE(config-if)#no shut
RouterE(config-if)#exit

Solution

First, each interface on each router needs to be added in RIP and version 2 has to be enabled:

RouterA(config)#router rip
RouterA(config-router)#version 2
RouterA(config-router)#network 192.168.1.0
RouterA(config-router)#network 172.16.0.0
RouterA(config-router)#end

RouterB(config)#router rip
RouterB(config-router)#version 2
RouterB(config-router)#network 192.168.1.0
RouterB(config-router)#network 172.18.0.0
RouterB(config-router)#end

RouterC(config)#router rip
RouterC(config-router)#version 2
RouterC(config-router)#network 192.168.1.0
RouterC(config-router)#network 172.20.0.0
RouterC(config-router)#end

RouterD(config)#router rip
RouterD(config-router)#version 2
RouterD(config-router)#network 192.168.1.0
RouterD(config-router)#network 172.17.0.0
RouterD(config-router)#end

RouterE(config)#router rip
RouterE(config-router)#version 2
RouterE(config-router)#network 192.168.1.0
RouterE(config-router)#network 172.19.0.0
RouterE(config-router)#end

The second item in the list states that RouterC should not learn any routes from the rest of the network, while the rest of the network should learn routes originated by it. RouterC also needs to have a default route to the rest of the network. To achieve this, RouterB’s f0/0 interface must be made passive so that it does not advertise the routes out this interface to RouterC while it still learns the routes advertised by RouterC. The configuration required is shown below:

RouterB(config)#router rip
RouterB(config-router)#passive-interface fa0/0

RouterC(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.5

The final item in the list states that routes should not be advertised out interfaces that do not connect to another router. This requires some interfaces on all routers to be passive:

RouterA(config)#router rip
RouterA(config-router)#passive-interface fa0/0

RouterB(config)#router rip
RouterB(config-router)#passive-interface fa0/1

RouterC(config)#router rip
RouterC(config-router)#passive-interface s0/0

RouterD(config)#router rip
RouterD(config-router)#passive-interface fa0/0

RouterE(config)#router rip
RouterE(config-router)#passive-interface fa0/0

Verification

To verify the solution, first check the routing table on each router. The routing table should resemble the output shown below:

RouterA#sh ip route
–output truncated—

Gateway of last resort is not set

R 172.17.0.0/16 [120/1] via 192.168.1.10, 00:00:10, Serial0/1
C 172.16.0.0/16 is directly connected, FastEthernet0/0
R 172.19.0.0/16 [120/2] via 192.168.1.10, 00:00:10, Serial0/1
[120/2] via 192.168.1.2, 00:00:01, Serial0/0
R 172.18.0.0/16 [120/1] via 192.168.1.2, 00:00:01, Serial0/0
R 172.20.0.0/16 [120/2] via 192.168.1.2, 00:00:01, Serial0/0
192.168.1.0/30 is subnetted, 5 subnets
C 192.168.1.8 is directly connected, Serial0/1
R 192.168.1.12 [120/1] via 192.168.1.2, 00:00:01, Serial0/0
C 192.168.1.0 is directly connected, Serial0/0
R 192.168.1.4 [120/1] via 192.168.1.2, 00:00:01, Serial0/0
R 192.168.1.16 [120/1] via 192.168.1.10, 00:00:10, Serial0/1

RouterB#sh ip route
–output truncated–

Gateway of last resort is not set

R 172.17.0.0/16 [120/2] via 192.168.1.14, 00:00:04, Serial0/1
[120/2] via 192.168.1.1, 00:00:02, Serial0/0
R 172.16.0.0/16 [120/1] via 192.168.1.1, 00:00:02, Serial0/0
R 172.19.0.0/16 [120/1] via 192.168.1.14, 00:00:04, Serial0/1
C 172.18.0.0/16 is directly connected, FastEthernet0/1
R 172.20.0.0/16 [120/1] via 192.168.1.6, 00:00:25, FastEthernet0/0
192.168.1.0/30 is subnetted, 5 subnets
R 192.168.1.8 [120/1] via 192.168.1.1, 00:00:02, Serial0/0
C 192.168.1.12 is directly connected, Serial0/1
C 192.168.1.0 is directly connected, Serial0/0
C 192.168.1.4 is directly connected, FastEthernet0/0
R 192.168.1.16 [120/1] via 192.168.1.14, 00:00:04, Serial0/1

RouterC#sh ip route
–output truncated–

Gateway of last resort is 192.168.1.5 to network 0.0.0.0

C 172.20.0.0/16 is directly connected, Serial0/0
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.4 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 [1/0] via 192.168.1.5

RouterD#sh ip route
–output truncated—

Gateway of last resort is not set

C 172.17.0.0/16 is directly connected, FastEthernet0/0
R 172.16.0.0/16 [120/1] via 192.168.1.9, 00:00:24, Serial0/1
R 172.19.0.0/16 [120/1] via 192.168.1.18, 00:00:01, Serial0/0
R 172.18.0.0/16 [120/2] via 192.168.1.18, 00:00:01, Serial0/0
[120/2] via 192.168.1.9, 00:00:24, Serial0/1
R 172.20.0.0/16 [120/3] via 192.168.1.18, 00:00:01, Serial0/0
[120/3] via 192.168.1.9, 00:00:24, Serial0/1
192.168.1.0/30 is subnetted, 5 subnets
C 192.168.1.8 is directly connected, Serial0/1
R 192.168.1.12 [120/1] via 192.168.1.18, 00:00:01, Serial0/0
R 192.168.1.0 [120/1] via 192.168.1.9, 00:00:24, Serial0/1
R 192.168.1.4 [120/2] via 192.168.1.18, 00:00:01, Serial0/0
[120/2] via 192.168.1.9, 00:00:24, Serial0/1
C 192.168.1.16 is directly connected, Serial0/0

RouterE#sh ip route
–output truncated–

Gateway of last resort is not set

R 172.17.0.0/16 [120/1] via 192.168.1.17, 00:00:09, Serial0/0
R 172.16.0.0/16 [120/2] via 192.168.1.17, 00:00:09, Serial0/0
[120/2] via 192.168.1.13, 00:00:19, Serial0/1
C 172.19.0.0/16 is directly connected, FastEthernet0/0
R 172.18.0.0/16 [120/1] via 192.168.1.13, 00:00:19, Serial0/1
R 172.20.0.0/16 [120/2] via 192.168.1.13, 00:00:19, Serial0/1
192.168.1.0/30 is subnetted, 5 subnets
R 192.168.1.8 [120/1] via 192.168.1.17, 00:00:09, Serial0/0
C 192.168.1.12 is directly connected, Serial0/1
R 192.168.1.0 [120/1] via 192.168.1.13, 00:00:19, Serial0/1
R 192.168.1.4 [120/1] via 192.168.1.13, 00:00:19, Serial0/1
C 192.168.1.16 is directly connected, Serial0/0

In the above outputs notice that RouterC does not have any RIP routes but all other routers know network 172.20.0.0/16.

A final verification can be done by sending a ping to 172.20.0.3 (interface s0/0 of RouterC) from RouterD as shown below:

RouterD#ping 172.20.0.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.20.0.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms

A successful ping shown that routing is working perfectly in the network.