Here is one of our Cisco CCNA 200-301 labs we have decided to provide FREE to you!  These labs were created and we felt they were not advanced enough for our partner’s CCNA Lab Workbook.  They are either not complex enough, do not cover multiple concepts, or do not have enough commentary explaining what we want to accomplish in each lab and why you are doing each step.  These labs are basically just simple configurations and not what we would really call labs. Why? Because they do not really help you learn.

Free Cisco CCNA v7 Lab – BGP – CertificationKits.com

Objective:

In this lab you will configure a complex environment consisting of BGP and OSPF.  You will then run basic testing commands to verify all links and protocols are working properly.

Hardware Requirements:

· Two Cisco routers with one serial port

· Two Cisco routers with two serial ports

· Cisco IOS 12.0 or higher

· A PC running a terminal emulation program

· Three back to back DTE/DCE serial cables

· Cisco console kit

Router Configurations

Router 1

Router#Config t

Router(config)#hostname R1

R1(config)#enable password cisco

R1(config-line)#line vty 0 4

R1(config-line)# password cisco

R1(config-line)# login

R1(config-line)#exit

R1(config)#interface Serial0/0

R1(config-if)#ip address 10.1.1.1 255.0.0.0

R1(config-if)#clockrate 64000

R1(config-if)#no shut

R1(config)# exit

R1(config)#interface Serial0/1

R1(config-if)#ip address 11.1.1.1 255.0.0.0

R1(config-if)#clockrate 64000

R1(config-if)#no shut

R1(config)#exit

R1(config)#router ospf 100

R1(config-router)# network 10.0.0.0 0.255.255.255 area 0

R1(config)#exit

R1(config)#router bgp 100

R1(config-router)# no synchronization

R1(config-router)# network 10.0.0.0

R1(config-router)# network 11.0.0.0

R1(config-router)# neighbor 10.1.1.2 remote-as 100

R1(config-router)# neighbor 10.1.1.2 route-reflector-client

R1(config-router)# neighbor 11.1.1.3 remote-as 100

R1(config-router)# neighbor 11.1.1.3 route-reflector-client

R1(config-line)#end

R1#wr

Router 2

Router#conf t

Router(config)#hostname R2

R2(config)#enable password cisco

R2(config)#line vty 0 4

R2(config-line)# password cisco

R2(config-line)# login

R2(config-line)# exit

R2(config)#interface Loopback0

R2(config-if)# ip address 2.2.2.2 255.255.255.255

R2(config-if)# no shut

R2(config-if)# exit

R2(config)#interface Loopback1

R2(config-if)# ip address 2.2.2.1 255.255.255.255

R2(config-if)# no shut

R2(config-if)# exit

R2(config)#interface Loopback3

R2(config-if)# ip address 2.2.2.3 255.255.255.255

R2(config-if)# no shut

R2(config)# exit

R2(config)#interface Serial0

R2(config-if)# ip address 10.1.1.2 255.0.0.0

R2(config-if)# no shut

R2(config-if)# exit

R2(config)#interface Serial1

R2(config-if)# ip address 12.1.1.2 255.255.255.0

R2(config-if)# no shut

R2(config-if)# exit

R2(config)#router ospf 100

R2(config-router)# network 2.2.2.1 0.0.0.0 area 1

R2(config-router)# network 2.2.2.2 0.0.0.0 area 0

R2(config-router)# network 2.2.2.3 0.0.0.0 area 1

R2(config-router)# network 10.0.0.0 0.255.255.255 area 0

R2(config-router)# network 12.0.0.0 0.255.255.255 area 1

R2(config-router)# exit

R2(config)#router bgp 100

R2(config-router)# no synchronization

R2(config-router)# network 2.2.2.1 mask 255.255.255.255

R2(config-router)# network 2.2.2.2 mask 255.255.255.255

R2(config-router)# network 10.0.0.0

R2(config-router)# network 12.0.0.0

R2(config-router)# neighbor 10.1.1.1 remote-as 100

R2(config-router)# neighbor 12.1.1.4 remote-as 200

R2(config-router)# exit

R2(config-line)#end

R2#wr

Router 3

Router#conf t

R3(config)#hostname R3

R3(config)#enable password cisco

R3(config)#line vty 0 4

R3(config-line)# password cisco

R3(config-line)# login

R3(config-line)# exit

R3(config)#interface Loopback0

R3(config-if)# ip address 3.3.3.3 255.255.255.255

R3(config-if)# no shut

R3(config-if)# exit

R3(config)#interface Loopback1

R3(config-if)# ip address 3.3.3.4 255.255.255.255

R3(config-if)# no shut

R3(config-if)#exit

R3(config)#interface Serial0

R3(config-if)# ip address 11.1.1.3 255.0.0.0

R3(config-if)# no shut

R3(config-if)# exit

R3(config)#router ospf 100

R3(config-router)# network 3.3.3.4 0.0.0.0 area 0

R3(config-router)# network 11.0.0.0 0.255.255.255 area 0

R3(config-router)# exit

R3(config)#router bgp 100

R3(config-router)# no synchronization

R3(config-router)# network 3.3.3.3 mask 255.255.255.255

R3(config-router)# neighbor 11.1.1.1 remote-as 100

R3(config-line)#end

R3#wr

Router 4

R4#conf t

R4(config)#hostname R4

R4(config)#enable password cisco

R4(config)#line vty 0 4

R4(config-line)# password cisco

R4(config-line)# login

R4(config-line)#exit

R4(config)#interface Loopback0

R4(config-if)# ip address 4.4.4.4 255.255.255.255

R4(config-if)# NO SHUT

R4(config-if)# exit

R4(config)#interface Serial0

R4(config-if)# ip address 12.1.1.4 255.0.0.0

R4(config-if)# clockrate 64000

R4(config-if)# no shut

R4(config-if)# exit

R4(config)#router ospf 100

R4(config-router)# network 4.4.4.4 0.0.0.0 area 1

R4(config-router)# network 12.0.0.0 0.255.255.255 area 1

R4(config-router)# exit

R4(config)#router bgp 200

R4(config-router)# no synchronization

R4(config-router)# network 12.0.0.0

R4(config-router)# neighbor 12.1.1.2 remote-as 100

R4(config-router)# end

R4(config-line)#end

R4# wr

Testing the Configuration

Router 1

R1# sho ip bgp

BGP table version is 22, local router ID is 11.1.1.1

Status codes: s suppressed, d damped, h history, * valid, > best, i – internal

Origin codes: i – IGP, e – EGP, ? – incomplete

Network          Next Hop            Metric LocPrf Weight Path

*>i2.2.2.1/32       10.1.1.2                 0    100      0 i

*>i2.2.2.2/32       10.1.1.2                 0    100      0 i

*>i3.3.3.3/32       11.1.1.3                 0    100      0 i

* i10.0.0.0         10.1.1.2                 0    100      0 i

*>                  0.0.0.0                  0         32768 i

*> 11.0.0.0         0.0.0.0                  0         32768 i

*>i12.0.0.0         10.1.1.2               128    100      0 i

R1#sho ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP

i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, * – candidate default

U – per-user static route, o – ODR, P – periodic downloaded static route

T – traffic engineered route

Gateway of last resort is not set

2.0.0.0/32 is subnetted, 3 subnets

O       2.2.2.2 [110/782] via 10.1.1.2, Serial0/0

O IA    2.2.2.3 [110/782] via 10.1.1.2, Serial0/0

O IA    2.2.2.1 [110/782] via 10.1.1.2, Serial0/0

3.0.0.0/32 is subnetted, 2 subnets

B       3.3.3.3 [200/0] via 11.1.1.3

O       3.3.3.4 [110/782] via 11.1.1.3, Serial0/1

4.0.0.0/32 is subnetted, 1 subnets

O IA    4.4.4.4 [110/846] via 10.1.1.2, Serial0/0

C    10.0.0.0/8 is directly connected, Serial0/0

C    11.0.0.0/8 is directly connected, Serial0/1

12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

O IA    12.1.1.0/24 [110/845] via 10.1.1.2, Serial0/0

O IA    12.0.0.0/8 [110/909] via 10.1.1.2, Serial0/0

R1#ping 4.4.4.4

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 56/58/60 ms

R1#ping 3.3.3.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/30/32 ms

Router 2

R2#sh ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP

i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, * – candidate default

U – per-user static route, o – ODR

Gateway of last resort is not set

2.0.0.0/32 is subnetted, 3 subnets

C       2.2.2.2 is directly connected, Loopback0

C       2.2.2.3 is directly connected, Loopback3

C       2.2.2.1 is directly connected, Loopback1

3.0.0.0/32 is subnetted, 2 subnets

B       3.3.3.3 [200/0] via 11.1.1.3, 01:25:31

O       3.3.3.4 [110/846] via 10.1.1.1, 00:18:03, Serial0

4.0.0.0/32 is subnetted, 1 subnets

O       4.4.4.4 [110/65] via 12.1.1.4, 00:25:19, Serial1

C    10.0.0.0/8 is directly connected, Serial0

O    11.0.0.0/8 [110/845] via 10.1.1.1, 00:18:04, Serial0

12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

O       12.0.0.0/8 [110/128] via 12.1.1.4, 00:25:19, Serial1

C       12.1.1.0/24 is directly connected, Serial1

R2#ping 4.4.4.4

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/31/32 ms

R2#ping 3.3.3.4

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 3.3.3.4, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 64/67/80 ms

R2#sho ip ospf nei

Neighbor ID     Pri   State           Dead Time   Address         Interface

11.1.1.1          1   FULL/  –        00:00:31 10.1.1.1        Serial0

4.4.4.4           1   FULL/  –        00:00:30 12.1.1.4        Serial1

R2#sho ip bgp

BGP table version is 18, local router ID is 2.2.2.2

Status codes: s suppressed, d damped, h history, * valid, > best, i – internal

Origin codes: i – IGP, e – EGP, ? – incomplete

Network          Next Hop            Metric LocPrf Weight Path

*> 2.2.2.1/32       0.0.0.0                  0         32768 i

*> 2.2.2.2/32       0.0.0.0                  0         32768 i

*>i3.3.3.3/32       11.1.1.3                 0    100      0 i

* i10.0.0.0         10.1.1.1                 0    100      0 i

*>                  0.0.0.0                  0         32768 i

*>i11.0.0.0         10.1.1.1                 0    100      0 i

*  12.0.0.0         12.1.1.4                 0             0 200 i

*>                  0.0.0.0                128         32768 i

R2#ping 4.4.4.4

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/31/32 ms

R2#ping 3.3.3.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 64/67/80 ms

Router 3

R3# sho ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP

i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, * – candidate default

U – per-user static route, o – ODR

Gateway of last resort is not set

2.0.0.0/32 is subnetted, 3 subnets

O       2.2.2.2 [110/846] via 11.1.1.1, 00:17:09, Serial0

O IA    2.2.2.3 [110/846] via 11.1.1.1, 00:17:09, Serial0

O IA    2.2.2.1 [110/846] via 11.1.1.1, 00:17:09, Serial0

3.0.0.0/32 is subnetted, 2 subnets

C       3.3.3.3 is directly connected, Loopback0

C       3.3.3.4 is directly connected, Loopback1

4.0.0.0/32 is subnetted, 1 subnets

O IA    4.4.4.4 [110/910] via 11.1.1.1, 00:17:09, Serial0

O    10.0.0.0/8 [110/845] via 11.1.1.1, 00:17:09, Serial0

C    11.0.0.0/8 is directly connected, Serial0

12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

O IA    12.1.1.0/24 [110/909] via 11.1.1.1, 00:17:09, Serial0

O IA    12.0.0.0/8 [110/973] via 11.1.1.1, 00:17:09, Serial0

R3# ping 4.4.4.4

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 92/96/112 ms

R3# ping 2.2.2.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2.2.2.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 64/68/84 ms

Router 4

R4#sho ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP

i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, * – candidate default

U – per-user static route, o – ODR

Gateway of last resort is not set

2.0.0.0/32 is subnetted, 3 subnets

B       2.2.2.2 [20/0] via 12.1.1.2, 02:10:14

O       2.2.2.3 [110/65] via 12.1.1.2, 01:40:45, Serial0

B       2.2.2.1 [20/0] via 12.1.1.2, 02:10:14

3.0.0.0/32 is subnetted, 2 subnets

B       3.3.3.3 [20/0] via 12.1.1.2, 02:10:14

O IA    3.3.3.4 [110/910] via 12.1.1.2, 01:33:24, Serial0

4.0.0.0/32 is subnetted, 1 subnets

C       4.4.4.4 is directly connected, Loopback0

B    10.0.0.0/8 [20/0] via 12.1.1.2, 02:10:14

B    11.0.0.0/8 [20/0] via 12.1.1.2, 02:10:14

12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

O       12.1.1.0/24 [110/128] via 12.1.1.2, 01:40:45, Serial0

C       12.0.0.0/8 is directly connected, Serial0

R4#sho ip ospf

Routing Process “ospf 100” with ID 4.4.4.4

Supports only single TOS(TOS0) routes

SPF schedule delay 5 secs, Hold time between two SPFs 10 secs

Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs

Number of external LSA 0. Checksum Sum 0x0

Number of DCbitless external LSA 0

Number of DoNotAge external LSA 0

Number of areas in this router is 1. 1 normal 0 stub 0 nssa

Area 1

Number of interfaces in this area is 2

Area has no authentication

SPF algorithm executed 3 times

Area ranges are

Number of LSA 6. Checksum Sum 0x4C45A

Number of DCbitless LSA 0

Number of indication LSA 0

Number of DoNotAge LSA 0

R4#sho ip bgp

BGP table version is 7, local router ID is 4.4.4.4

Status codes: s suppressed, d damped, h history, * valid, > best, i – internal

Origin codes: i – IGP, e – EGP, ? – incomplete

Network          Next Hop            Metric LocPrf Weight Path

*> 2.2.2.1/32       12.1.1.2                 0             0 100 i

*> 2.2.2.2/32       12.1.1.2                 0             0 100 i

*> 3.3.3.3/32       12.1.1.2                               0 100 i

*> 10.0.0.0         12.1.1.2                 0             0 100 i

*> 11.0.0.0         12.1.1.2                               0 100 i

*  12.0.0.0         12.1.1.2                 0             0 100 i

*>                  0.0.0.0                  0         32768 i

R4#ping 3.3.3.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 84/88/92 ms

R4#ping 2.2.2.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2.2.2.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/30/32 ms

End of Lab

BGP Review

Select  from the italic  terms below that correspond with the definitions provided.

AS        eBGP   iBGP    Syncronization Requirement

  1. __________  A logical domain under the control of a single entity
  2. __________  BGP adjacencies which span autonomous system boundaries
  3. __________  BGP adjacencies formed within a single autonomous system
  4. __________  A route must be known by an IGP before it may be advertised to BGP peers

Match the Neighbor States below to the terms underneath.

Neighbor State Definition

  1. ____ Neighbor is not responding
  2. ____ Attempting to connect
  3. ____ TCP session established
  4. ____ Open message sent
  5. ____ Response received

10.  ____ Adjacency established

Neighbor State Terms

  1. Open Confirm
  2. Open Sent
  3. Connect
  4. Idle
  5. Active
  6. Established

Answers:

  1. Autonomous System (AS)
  2. External BGP (eBGP)
  3. Internatl BGP (iBGP)
  4. Synchronization Requirement
  5. D
  6. E
  7. C
  8. B
  9. A
  10. F